Un total de 6 pages ont été trouvées avec le mot clé Jeux vidéo.

Création de jeux vidéos

Cet atelier a pour but la présentation des métiers du jeu vidéo par le biais d'une pratique de création.

Il résulte d'une démarche collective du Groupe de Travail Jeux Vidéo (GTJV) qui a rassemblé en 2018-2019 des médiateurs numériques de la Loire et en particulier des Espaces Publics Numériques de Saint-Étienne.

L'animation se découpe en 4 séquences d'une demi-journée, respectivement consacrées aux principaux aspects de la création vidéoludique que sont
- la programmation,
- le game design,
- le character design,
- et le level design.

Nous présentons ainsi un florilège de métiers du jeu vidéo, ainsi que des méthodes et des outils (libres et gratuits) pour les comprendre et s'y initier.

! Pour démarrrer, pensez plutôt à Pong, pas à Call of Duty...

Le séquençage de l’animation

Présentation de l’atelier et accompagnement au suivi du tutoriel stencyl crash course en accompagnement avec les participants.

Déroulé de la première séance :
1. Accueil des participants (5 minutes).
2. Présentation de l'atelier (5 minutes).
3. Présentation des "types de jeux vidéo" sous forme ludique.
4. Présentation des métiers du jeu vidéo (5 minutes).
5. Timeline avec les grands jeux marquants afin d'échanger sur "la petite histoire du jeux vidéo", leurs dates de sorties et l'âge conseillé pour y jouer (10 minutes).
6. Création d'un jeu vidéo avec le tutoriel d'initiation "//Stencyl Crash Course//".

Matériel: PC sous Mac OS, Windows, ou Linux

Logiciel utilisé : Stencyl

Stencyl est un outil de développement de jeu vidéo qui permet de créer des jeux vidéo en 2D, à destination d'ordinateurs, de téléphones et du web. Son utilisation globale est gratuite et certaines options sont proposées en supplément payant. (source Wikipedia)

Stencyl utilise un langage de programmation par blocs, adapté à son utilisation par des débutants, des enfants et adolescents.

Tutoriel détaillé aux formats texte et vidéo sur notre page: **Stencyl, première prise en main avec le Kit de cours accéléré**

Définition du game design : processus de création et de mise au point des règles et autres éléments constitutifs d'un jeu.

Source : Wikipédia



Déroulé de la deuxième séance :
1. Accueil des participants (5 minutes).
2. Présentation de l'atelier (5 minutes).
3. Présentation des types de jeux réalisables avec Stencyl (voir liste ci-après) afin de découvrir les possibilités du moteur de création de jeu (15 minutes).
4. Création de l’univers, esquisse et game design sur papier (25 minutes).
5. Création d'un jeu vidéo avec Stencyl.

Jeux créés sous Stencyl

1. Reaching Finality, RPG Zelda like



2. Skull Face, jeu de plateforme



3. Tiny Island Adventure, jeu de plateforme



4. Reflex and dexterity test, jeu de réflexes



5. Autres exemples de Game Design
- Notice Me: jeu en équipe ; le but du jeu est de se faire remarquer, dans un espace public. Les points sont marqués en faisant plus de bruit que le bruit ambiant.
- Control, réflexion sur un game design où le pointeur de la souris est un personnage.

Définition du character design : spécialisation du game design dans la création des personnages et élements de décor interactifs.



Character designer, ou concepteur de personnages, est un terme utilisé notamment dans le monde de l'animation, de la bande dessinée (principalement comics et manga), au cinéma et dans les séries télévisées (notamment de science-fiction), ainsi que dans le jeu vidéo, pour désigner une personne chargée de créer la charte graphique, d'animation, et parfois, psychologique, des personnages d'un projet.

Le character designer peut aussi être la personne (ou une des personnes) qui doit représenter les personnages qu'il a créés tout au long du projet, mais son travail consiste avant tout à imaginer une représentation graphique des personnages. (source wikipédia)

Logiciel utilisé : Piskel
- Création des sprites acteurs
Voir le tutoriel de Piskel



Définition du level design : processus qui s'occupe de la réalisation des niveaux, ou « cartes », de jeu (level ou map en anglais). C'est une phase importante qui a son influence sur le gameplay final du jeu. Plutôt que de concevoir des règles comme le Game designer, le level designer applique les mécaniques de gameplay dans le niveau, essayant de tirer un tout plausible, cohérent et varié. Son rôle n'est pas de concevoir graphiquement les éléments mais de décider comment ils seront disposés à l'intérieur du niveau (obstacles, ennemis, bonus, décors...).

Le level design est bien plus que de la création de cartes jouables ; c'est la prise en compte de nombreux paramètres comme le gameplay général du jeu, l'évolution et le niveau du joueur, la crédibilité de la carte dans le seul but de procurer du plaisir ludique.

Source : Wikipédia



Différence entre level design et game design : Fonctions distincetes mais proches

Logiciel utilisé : Tiled
Création des tuiles : Tutoriel complet sur Tiled Map Editor

image Capture_decran_tiled.png (37.6kB)
Tiled, création de tuiles de jeux

Finitions

Level design du jeu sur stencyl, test final et insertion de musique avec Audacity directement dans Stencyl.

Les ressources

- Pixelart.fr : outils de création de pixelart, des sites où trouver du pixelart, des jeux exemplaires au niveau du graphisme pixelart, des ressources sonores, et autres... en OpenSource .
- Opengameart.org : des milliers de sprites et de tuiles en OpenSource , et en Anglais.
- Les métiers du jeu vidéo par jeuxvideos.com

La logithèque

- Stencyl moteur de création de jeu. Utilisable sur Windows 10, Mac Os et Linux.
- Piskel : création de sprite en pixel art. Utilisation en ligne ou à télécharger sur un ordi équipé de Windows 10, Mac Os et Linux.
- Tiled Map Editor: création de map et de tuile de jeu. Utilisable sur Windows 10, Mac Os et Linux.
- Audacity: gestion de la musique et des sons. Logiciel libre utilisable sur Windows 10, Mac Os et Linux.
- Patatap, création de sons à partir du clavier de l'ordinateur




Wiktionnaire : c'est quoi tous ces mots barbares ?

- VPL, Langages de Programmation par blocs
- Pixel Art sur le wiktionnaire sur Wikipedia et sur Wikimedia
- RPG, abréviation de Role Playing Game, ou Jeu vidéo de Rôle, sur le wiktionnaire, sur Wikipedia et sur Wikimedia
- Sprite sur le wiktionnaire, sur Wikipédia et sur Wikimedia

Exemples

Dans la Loire

Saint-Étienne

Animation Rétrogaming parent-enfants

Cette animation est basée sur les compétences psychosociales acquises en jouant aux jeux vidéo, animation a vivre pendant un temps parents/enfants.

image mario2.png (0.5MB)
Au sens large, le retrogaming est le fait de jouer à des jeux vidéo antérieurs à la génération actuelle de consoles ou d’ordinateurs. Une autre définition, plus restrictive, limite ces jeux aux consoles ou ordinateurs qui ne sont plus disponibles sur le marché. Le retrogaming irait donc des tout premiers jeux vidéo à la console Dreamcast de Sega (fin de production en 2001).
Plus d'exemple de de définition ici : https://www.retrogaming.fr/le-retrogaming-definition/
Cette animation est basée sur les compétences acquises en jouant aux jeux vidéo, animation a vivre pendant un temps parents/enfants.
En nous basant sur le stock conséquent de jeux vidéo et de consoles que possède zoomacom, nous avons classé les jeux en 10 catégories :

  • Combat (street fighter 2, soul calibur, tekken 2)
  • Beat them all (street of rage)
  • Plates-formes (super mario bros, rayman)
  • Shoot them up (parodius, starwing)
  • Tir objectif (Tomb raider, die hard trilogy)
  • Tir subjectif (Golden eye 007, Alien trilogy)
  • Puzzle (bust a move 2, Dr mario)
  • Combat motorisé (mario kart, vigilante 8)
  • Course ( Gran turismo, V-rallye)
  • Sport (Fifa, california games)

Les jeux retenus ont été testés et examinés afin de mieux comprendre leurs fonctionnement et les compétences que l’on peut développer en jouant à ceux-ci.

Les compétences psychosociales


Les compétences psychosociales sont la capacité d’une personne à répondre avec efficacité aux exigences et aux épreuves de la vie quotidienne. C’est l’aptitude d’une personne à maintenir un état de bien-être mental, en adoptant un comportement approprié et positif à l’occasion des relations entretenues avec les autres, sa propre culture et son environnement” (Source OMS)

Ce sont ces compétences que l’on a choisies pour parler des jeux vidéo avec les parents et leurs enfants.

L’idée pendant cette activité rétro-gaming est d’expliquer les compétences psychosociales aux parents et aux enfants, de laisser à disposition le “visuel” et de commencer à jouer.
Les parents et les enfants jouent ensemble aux jeux choisies et toutes les 10 min environ, ils doivent noter les compétences qu’ils pensent avoir développé pendants ce temps de jeux et changer pour le jeu suivant.

Le fait de lister les compétences acquises pendant le jeu permet aux parents comme aux enfants de mieux comprendre ce qu’ils viennent de vivre à travers ce jeu, ils en discutent, débattent pour arriver a un consensus ensemble.
A la fin de l’animation un temps collectif ou par “famille” permet d’échanger ensemble sur les compétences acquises pendant l’animation, de les lister et de mettre en lumière les apports des différents jeux et permettre de mieux comprendre pourquoi on joue et ce que ça nous apporte.
Une fois la méthode d’animation expliquée, place aux règles du jeux, elles sont simples :

En gros, 8 min sur chaque jeux, sachant que pour le premier tour 10 jeux sont testés, ça nous donne 80min ou 1h20, sachant que le temps de mise en place sera d’une vingtaine de minute.
Toutes les 8min vous userez donc d’un klaxon pour faire changer tout le monde de console.
Le reste du temps permettra de tester d’autres jeux “pour le fun” uniquement.

Le matériel nécessaire pour cette animation

Pour une animation avec 10 groupes de parents / enfants :

  • 5 consoles minimum
  • 10 jeux(2 par consoles)
  • 5 rallonges
  • 2/3 multiprises
  • Le visuel rétrogaming
  • Le visuel sur les compétences psychosociales
  • Un klaxon
image StChamGWpolygon.jpg (0.2MB)


Voir aussi

Parentalité et jeux vidéo: les animations Retrogaming avec Zoomacom (article sur le site de Zoomacom)

Les différents types de jeu vidéo (affiche exposition Super Demain 2016)

Rétrogaming Défi des Kamis

Cette animation retrogaming vous transporte dans l'univers japonais des samouraïs.
Avec différentes consoles de jeux vidéo rétros (retrogaming) et des jeux se déroulant dans un univers "japonisant", ainsi qu'un scénario basé sur la Bataille de Shiroyama.

image Le_dfis_des_kamis1.png (3.6MB)
Au sens large, le retrogaming est le fait de jouer à des jeux vidéo antérieurs à la génération actuelle de consoles ou d’ordinateurs. Une autre définition, plus restrictive, limite ces jeux aux consoles ou ordinateurs qui ne sont plus disponibles sur le marché. Le retrogaming irait donc des tous premiers jeux vidéo à la console Dreamcast de Sega (fin de production en 2001).
D'autres définitions ici : https://www.retrogaming.fr/le-retrogaming-definition/

Le scénario

Pour cette animation, nous avons imaginé et créé un court scenario :
"Le moment de la grande offensive est arrivé, vous venez de prendre la colline de Kagoshima, vous le savez, le jour de la grande Bataille de Shiroyama est arrivé !

Les troupes impériales du général Yamagata Aritomo sont à vos trousses, mais pour le moment vous tenez bon...

Tout d'un coup le ciel s'assombrit, un éclair foudroie votre clan!
Le général Aritomo a invoqué les kamis pour vous jeter un sortilège.

Vous allez devoir vous battre en étant handicapés par ces sortilèges, faire preuve d’ingéniosité et de combativité pour honorer le bushido"


Déroulement

L'animation est basée sur 20 joueuses (ou joueurs) .
Les samouraïs ne se battent pas pour gagner la bataille... c'est cuit pour eux (500 contre 30 000, c'est pas top). Ils se battent pour leur honneur, et montrer suffisamment de bravoure pour que les survivants puissent mener la cérémonie du seppuku.

Pour cela, l'animation se déroule en plusieurs batailles.
La première bataille
1. Les joueuses sont séparées en 2 camps : 10 samouraïs et 10 soldats impériaux.
2. Les samouraïs tirent chacune une carte de Kami.
Chaque carte indique le handicap causé par la malédiction du Kami, et le jeu sur lequel le samouraï va affronter son adversaire.
L'animateur note
3. Le samouraï défie un soldat impérial, et ils se rendent tous les deux sur leur lieu de bataille, c'est-à-dire devant le jeu indiqué par le Kami.
4. Les deux adversaires lisent les instructions du Kami sur les conditions de victoire, indiquées sur une carte présente sur la console.
5. Les deux adversaires peuvent demander de l'aide à l'animateur de la séance à tout moment, et signalent la victoire de l'un d'entre eux au bout du temps imparti (en général 15 minutes, mais des fois ça va plus vite).
6. L'animateur note les points gagnés par les joueuses :
- 5 points pour chaque victoire d'un samouraï,
- 2 points pour chaque victoire d'un soldat impérial.
7. L'animateur annonce la victoire des samouraïs ou des soldats pour la bataille, et le note sur le tableau
L'animateur vérifie que les handicaps sont bien respectés, et élimine un des adversaires en cas de non-respect du handicap.
Batailles suivantes
1. Les joueuses changent de camp.
Celles qui étaient samouraïs deviennent soldats de l'empire, et inversement.
2. Tout se déroule comme à la 1ère bataille, à quelques exceptions près :
- la même joueuse ne peut pas avoir 2 fois le même handicap
- les samouraïs essaient de défier des soldats différents, pour affronter différents adversaires lors des différentes batailles
3. Les batailles s'enchainent jusqu'à épuisement des joueuses ou des animateurs.
L'honneur des samouraïs
À la fin des batailles, il est l'heure de faire les comptes :
1. Si les samouraïs ont remporté plus de batailles, ils ont sauvé leur honneur, et mènent la cérémonie du seppuku. L'animateur décrit cette cérémonie brièvement.
2. Si les soldats de l'empire ont remporté plus de batailles, l'honneur des samouraïs est bafoué, ils sont abattus comme des chiens galeux. L'animateur décrit cette scène brièvement.
3. Il est temps de parler des handicaps causés par les Kamis, et du ressenti des joueuses :
- Comment ont-elles ressenti le fait d'avoir un handicap?
- Comment ont-elles ressenti le fait d'affronter un adversaire avec un handicap?
La discussion peut durer 15-20 minutes, pour rester légère.

Les Kamis

Nous intégrons également un descriptif des différents Kamis qui "interviennent" pendant l'animation :
  • Izanami, la déesse de la création et de la mort
  • Izanagi, le dieu de la création
  • Amaterasu, la déesse du soleil
  • Hachiman, le dieu de la guerre
  • Kotoamatsukami, nom collectif des premiers kamis au moment de la création de l'univers
  • Omoikane, la déesse de la sagesse
  • Tsukuyomi, le dieu de la lune
  • Susanoo, le dieu des mers et de la tempête
  • Saruta-hiko, le dieu de la terre
  • Uzume, la déesse de la gaieté
  • Ryūjin, le dieu dragon de la mer et des éclairs
  • Shinigami, nom des dieux psychopompes
  • Raiden, le dieu du tonnerre
  • Fujin, le dieu du vent

Les handicaps

Dans notre scénario, les kamis ont lancés un sortilège à nos valeureux samouraïs. Nous avons donc créé des cartes avec différents handicaps, que les participants vont devoir surmonter pour pouvoir jouer convenablement.

Les handicaps sont les suivants :
  • Main gauche inutilisable
  • Main droite inutilisable
  • Jambe gauche inutilisable
  • Jambe droite inutilisable
    image kamicarte1.png (0.2MB)
  • Œil droit inutilisable
  • Œil gauche inutilisable
  • Pouces inutilisables
  • Trouble visuel
Pour marquer le handicap et les aider à le respecter, des bandeaux de tissu rouge seront "noués" aux endroits adéquats.

Les objectifs pédagogiques

- Découvrir les jeux vidéo rétro
- Jouer en groupe
- Comprendre le handicap en se mettant "à la place de"
- Découvrir la culture japonaise

Les Compétences psychosociales

Pendant cette animation, les participant·e·s vont travailler les compétences suivantes :
  • Savoir communiquer efficacement
  • Avoir conscience de soi
  • Avoir de l'empathie pour les autres
  • Savoir résoudre les problèmes

Pour une animation avec 20 participants (à adapter suivant le nombre de participant·e·s)
  • 10 consoles
  • 2 jeux par console
  • 10 tv cathodiques
  • Rallonges + multiprises
  • Affiches Kamis
  • Cartes Kamis
  • Bandes de tissu (rouge)



Voir aussi

Parentalité et jeux vidéo : les animations Retrogaming avec Zoomacom (article sur le site de Zoomacom)
Les différents types de jeu vidéo (affiche exposition Super Demain 2016)

Création d'un sprite animé avec Piskel

Piskel est un logiciel utilisable directement dans votre navigateur ou téléchargeable sur leur site.

Il permet de réaliser facilement des grilles de sprites (lutins) pour jeux vidéo, avec une interface simple mais très complète.

Ce qui est intéressant avec Piskel, c’est d’abord la possibilité de travailler avec des "calques" et surtout de pouvoir créer plusieurs "frames" pour exporter au final soit un GIF animé de votre conception, soit une planche de toutes les images dessinées, pour les importer dans un logiciel de conception de jeux.

L’outil est gratuit et sous licence libre.

Aller sur le site Piskel - Free online sprite editor

Pour commencer nous allons donc créer une licorne qui vomit un arc-en-ciel et qui, aulieu de mourir fais caca pendant genre 10 secondes (c'est une idée qui vaut ce qu'elle vaut, je vous l'accorde...)
Alors, on commence par ouvrir le logiciel Piskel, téléchargé au dessus, et on « Resize » le sprite en 50*50px.

Première frame

image licorne1.png (31.4kB)
Clique sur « pen tool » pour commencer à tracer le contour de ton dessin pixel par pixel.
Pour agrandir ou réduire ta zone de dessin, joues avec la molette de ta souris. Une fois que tu as tracé ton dessin, tu va créer un nouveau calque pour la couleur de ton dessin :
Va sur fenêtre « layers » (calques, ou couches) à droite et tu cliques sur + pour créer un nouveau layer.
Sur ce calque, tu vas ajouter la couleur à ton dessin.

Créer un calque te permet de mieux gérer les différentes parties de ton dessin.

Seconde frame

image licorne2.png (30.9kB)
Ensuite, tu vas dupliquer ta Frame. Sur ta frame en haut a gauche tu survoles et cliques sur Duplicate this frame. Cette seconde frame va nous permettre de faire bouger les pattes des licornes vers l’avant.

En dupliquant la 1re frame, tu as copié l’intégralité du dessin (donc les 2 layers)

Tu as donc besoin sur la 2e frame de bouger les jambes vers la droite. Pour cela, tu effaces une partie de la jambe et la refais en la décalant sur la droite.
Ensuite tu vas sur le second layer et tu bouges aussi la couleur des sabots, car comme tu as bougé le contour des pattes, la couleur doit bouger aussi.

Troisième frame

image licorne3.png (30.3kB)
De nouveau, tu vas dupliquer la 1re frame. Cette troisième frame va nous permettre de faire bouger les pattes de la licorne vers l’arrière.
Tu as donc besoin sur la 3ᵉ frame de bouger les jambes vers la gauche.

Pour cela, tu effaces une partie de la jambe et la refais en la décalant sur la gauche.

Ensuite tu vas sur le second layer et tu bouges aussi la couleur des sabots, car comme tu as bougé le contour des pattes, la couleur doit bouger aussi.

Quatrième frame

image Capture3.png (33.2kB)
De nouveau, tu vas dupliquer la 1re frame. Cette quatrième frame va nous permettre de créer le vomi arc-en-ciel
Pour ce faire, tu vas sur le layer 2 et tu créés un arc-en-ciel au niveau de la bouche de la licorne.

Cinquième frame

image Capture4.png (36.1kB)
De nouveau, tu vas dupliquer la 1re frame. Cette cinquième frame va nous permettre de créer le « caca d’attente » (au lieu de perdre et de recommencer au début du niveau, tu dois attendre et regarder la licorne faire caca pendant 10 secondes).

Pour ce faire, tu vas sur le layer 2 et tu créés un caca au niveau de la croupe de la licorne.

Les frames et les calques sont importants pour pouvoir retoucher facilement les différents mouvements de ton dessin, si tu faisais tout le dessin sur un seul et même frame ou layer, tu serais obligé d’effacer a chaque nouvelle idée et surtout tu ne pourrais pas créer une animation.

Voila pour le tutoriel Piskel Licorne, maintenant que tu sais faire la licorne, un monde nouveau s'ouvre à toi!

Menus à gauche de l'écran (partie gauche)

Menu des Outils

image Capture_numrot.png (22.5kB)
1 Pen size / Taille du stylo : Il permet de jouer avec la taille du stylo, il part d'un point de 1px (1 carré) pour arriver a 4px (16 carrés) au maximum.

2 Pen tool / Outil stylo : Il permet de dessiner. C'est avec lui que vous allez créer les "points pixel" qui serviront à construire votre "pixel art".

3 Vertical mirror pen / Stylo miroir vertical : comme le stylo, il permet de dessiner mais cette fois avec un effet miroir vertical (suivant l'axe vertical).
Si vous dessinez avec le stylo miroir à gauche de votre "feuille", le même dessin sera créé symétriquement à droite.
Si vous appuyez simultanément sur la touche CTRL alors que vous dessinez, c'est avec l'axe horizontal que l'effet miroir sera créé.
Et si vous appuyer simultanément sur la touche shift / MAJ c'est avec l'axe horizontal et vertical que vous dessinerez.

4 Paint bucket tool / Outil pot de peinture : Il permet de remplir un carré, un groupe de carré ou le fond de l'image avec la couleur unie de votre choix.

5 Paint all pixels of the same color / Peindre tous les pixels de la même couleur : Il permet de peindre tous les carrés de la même couleur.
Si vous appuyer simultanément sur la touche CTRL, vous appliquerez cet effet à tous les calques.
Si vous appuyer simultanément sur la touche Shift / MAJ, vous appliquerez cet effet à tous dessins / frames.

6 Eraser tool / Outil gomme : Comme son nom l'indique, il permet de gommer. Comme pour l'outil stylo, on fait varier sa taille avec l'outil "Pen size / Taille du stylo".

7 Stroke tool / Outil ligne et diagonale : Il permet de créer des lignes et diagonales en partant d'un point fixe.
En appuyant simultanément sur shift / MAJ, la diagonale ou ligne reste droite.

8 Rectangle tool / Outil rectangle : Il permet de créer le contour d'un rectangle (vous pouvez ensuite le remplir avec l'outil pot de peinture).
En appuyant simultanément sur shift / MAJ, vous maintiendrez un rapport de 1 à 1, cela veut dire que votre rectangle ne sera pas déformé.

9 Circle tool / Outil cercle : Il permet de créer le contour d'un cercle (vous pouvez ensuite le remplir avec l'outil seau de peinture).
En appuyant simultanément sur shift / MAJ, vous maintiendrez un rapport de 1 à 1, cela veut dire que votre cercle sera un vrai cercle et ne sera pas déformé (ovale).

10 Move tool / Outil mouvement : Il permet de déplacer votre dessin.
Si vous appuyer simultanément sur la touche CTRL, vous appliquerez cet effet à tous les calques.
Si vous appuyer simultanément sur la touche Shift / MAJ, vous appliquerez cet effet à tous les dessins / frames.
Si vous appuyer simultanément sur la touche ALT, cela aura pour effet de "cloner" votre dessin.

11 Shape selection / Choix de la forme : Cet outil vous permet de sélectionner et de faire glisser la "forme / sélection" de votre choix.
Si vous appuyer simultanément sur la touche CTRL+C, vous copiez la zone sélectionnée.
Si vous appuyer simultanément sur la touche CTRL+V, vous collez la zone sélectionnée.
Maintenez la touche shift / MAJ pour déplacer le contenu.

12 Rectangle selection / Sélection rectangulaire : Il permet de sélectionner un élément via une forme rectangulaire.
Si vous appuyer simultanément sur la touche CTRL+C, vous copiez la zone sélectionnée.
Si vous appuyer simultanément sur la touche CTRL+V, vous collez la zone sélectionnée.
Maintenez la touche shift / MAJ pour déplacer le contenu.

13 lasso selection / Sélection au lasso : Il permet de sélectionner un élément en créant une forme libre de votre choix. Avec le lasso vous créez vous-même la forme de la zone que vous voulez sélectionner.
Si vous appuyer simultanément sur la touche CTRL+C, vous copiez la zone sélectionnée.
Si vous appuyer simultanément sur la touche CTRL+V, vous collez la zone sélectionnée.
Maintenez la touche shift / MAJ pour déplacer le contenu.

14 Lighten / Éclaircir : Cet outil vous permet d'éclaircir ou d'obscurcir les pixels de votre dessin, il permet aussi de créer une sorte de dégradé.
Si vous appuyer simultanément sur la touche CTRL, vous allez obscurcir la partie souhaitée.
Si vous appuyer simultanément sur la touche shift / MAJ, vous allez appliquer l'effet une seule fois par pixel.

15 Dithering tool / Outil de tramage : Il permet de créer une trame, un damier de couleurs choisies.

16 Color picker / Sélecteur de couleurs : Il permet de sélectionner une couleur pour pouvoir s'en servir sur une autre forme, calque ou dessin.

Autres

L'éditeur de couleur

image Capture_couleur.png (1.2kB)
Editeur de couleur
Il y a 2 carrés de couleur, l'un pour la couleur première et l'autre pour la secondaire, en cliquant sur le carré vous choisissez la couleur que vous souhaitez, soit à l’aide de l’outil Pipette, des panneaux Couleur et Nuancier ou avec les couleurs sous forme de valeur hexadécimale (#000000).

Frame / Cadre

Le cadre / Frame est votre fenêtre de "dessin".
image Captureframe.png (2.8kB)
On peut créer autant de frame que l'on veut, les frames sont comme des calques, ils sont utilisés pour effectuer des opérations telles que la composition d’images multiples, l’ajout de texte à une image ou l’ajout de formes à une image vectorielle.
Il peuvent être déplacés de haut en bas pour choisir leurs niveaux d'importance.
Ils peuvent aussi être dupliqués.
Il faut vraiment les imaginer comme des feuilles de papier calque.
image 450pxCaptureframeg.png (84.3kB)


Pour la partie droite

image CaptureGauche.png (26.5kB)
1 Fenêtre de visualisation : Avec cette fenêtre vous pouvez visualiser en direct votre animation.
Vous pouvez régler la taille de votre animation :
Original size preview / Aperçu du format original
Best size preview / Aperçu du meilleur format
Full size preview / Aperçu du format en taille réelle.

- Toggle Grid / Basculer la grille : Il vous permet de faire apparaitre ou non la grille pour créer votre dessin.
- Open preview in popup / Ouvrir la prévisualisation dans une fenêtre popup: Permet d'ouvrir et de visualiser l'animation dans une nouvelle fenêtre.

2 Toggle onion screen / "Basculer à la visualisation en "couches d'oignon": Permet de visualiser ou non les différents "frames et layers" sur votre fenêtre principale.

3 Curseur FPS : Le curseur permet d'augmenter ou de diminuer la vitesse de votre animation.

4 Layers / Couche : Sensiblement la même chose que Frame, a la différence près que les "dessins" créés avec "layers" sont fixes, ils ne bougeront pas au sein de votre animation.

Partie "Transform"

5 Flip vertically / Basculer verticalement : Il applique un effet miroir vertical à votre dessin.
Si vous appuyez simultanément sur la touche ALT, vous appliquez un effet miroir horizontal.
Si vous appuyez simultanément sur la touche Shift / MAJ, vous appliquerez cet effet à tous dessins / frames.
Si vous appuyez simultanément sur la touche CTRL, vous appliquerez cet effet à tous les layers .

6 Counter-clockwise rotation / Rotation dans le sens inverse des aiguilles d'une montre : Permet de faire tourner votre "dessin" dans le sens inverse des aiguilles d'une montre.
Si vous appuyer simultanément sur la touche ALT, vous ferez tourner votre dessin dans le sens des aiguilles d'une montre.
Si vous appuyer simultanément sur la touche Shift / MAJ, vous appliquerez cet effet à tous dessins / frames.
Si vous appuyer simultanément sur la touche CTRL, vous appliquerez cet effet à tous les layers.

7 Clone current layer to all frames / Cloner le calque sur toutes les frames / images : Il permet de cloner votre dessin sur toutes les frames que vous avez créées. Attention: il clone la frame active (celle qui est entourée de jaune).

8 Align image to the center / Aligner et centrer votre image : Il permet d'aligner et de centrer correctement votre image.
Si vous appuyer simultanément sur la touche Shift / MAJ, vous appliquerez cet effet à tous les dessins / frames.
Si vous appuyer simultanément sur la touche CTRL, vous appliquerez cet effet à tous les layers.

9 Crop the sprite / recadrer le sprite (zone de dessin) : Cet outil vous permet de recadrer votre zone de dessin, mais attention, l'outil est appliqué sur toutes les frames et layers en même temps.

10 L'outil palette vous permet de prédéfinir des couleurs pour ensuite vous en servir via l'éditeur de couleur.
En cliquant sur le petit icone stylo, vous pouvez gérer la palette, une fenêtre s'ouvre et vous pouvez ajouter ou supprimer et renommer des palettes de couleurs.

Barre de menu

image Captured.png (8.8kB)
- Préférences :
1 Settings / Misc :
Background: Permet de régler la luminosité et le contraste du fond "transparent" de votre sprite / dessin.
Layer opacity : Permet de régler l'opacité et donc la visibilité de vos layers.
Maximum FPS : Permet de régler la vitesse maximum pour le curseur FPS vu ci-dessus.
Color format : Permet de choisir le format de couleur RGB ou HEX.

Settings / Grid (grille):
Enable grid / activer la grille : Permet d'activer ou non la grille pour dessiner les "carrés".
Grid size / taille de la grille : Permet de gérer la taille de la grille en pixel.
Grid spacing / Espacement de la grille : Permet de gérer l'espacement de la grille en pixel.
Grid color / Couleur de la grille : Permet de gérer la couleur de l'espacement de la grille.

Settings / Tile mode ( Mode carrelage):
Enable tile mode / Activer le mode carrelage : Activer ou désactiver le mode carrelage.
Mask opacity / Opacité du masque : Permet de gérer la transparence du mode carrelage.

image Captured.png (8.8kB)
2 Resize / Redimensionner :
Permet de redimensionner votre "dessin".
(widtht/largeur),(height/longueur)
Maintain aspect ratio / Maintenir le rapport hauteur/largeur : Cocher cette case permet de ne pas déformer votre dessin, vous l'agrandissez mais dans des proportions égales au dessin de base.
resize canvas content / redimensionner le contenu du canevas : Permet de redimensionner le contenu du canvas.

Default size / Dimension par défaut : Permet de définir les dimensions par défaut de vos dessins.

image Captured.png (8.8kB)
3 Save / Sauvegarde :
Sprite information : Vous pouvez ici, créer un titre et une description pour votre sprite/dessin

Save offline as file / Enregistrer hors ligne sous forme de fichier : Votre fichier sera enregistré sur votre pc sous le format ".piskel".

Save offline in browser / Enregistrer hors ligne dans votre navigateur :
Save Online : Permet de sauvegarder directement sur le site internet piskelapp.com si vous avez créé un compte utilisateur au préalable.

image Captured.png (8.8kB)
4 Export / Exporter
Scale / Mettre a l'échelle : Permet de mettre à l’échelle en maintenant les proportions (Aspect ratio).
GIF,PNG,ZIP...: permet d'exporter votre dessin au format désiré.

5 Import / Importer :
Load from browser / Importer à partir du navigateur
Load .piskel file / Importer un fichier .piskel depuis votre ordinateur.
Import from picture / Importer une image.
Recover recent sessions / Récupérer les sessions précédentes : Permet de récupérer vos sessions précédentes et travailler dessus.

Stencyl, première prise en main avec le Kit de cours accéléré


(Ce tutoriel est une traduction complétée par Zoomacom (travail collectif) de l'article Crash Course: Let's Make a Game! rédigé par Jon sur Stencylpedia)

Introduction

Ce tutoriel court et pratique vous guidera à travers les étapes nécessaires pour créer un jeu de plateforme simple en utilisant un élément pré-construit: le Crash Course Kit (Cours accéléré).

Un kit pour Stencyl est un gabarit complet de jeu livré avec des ressources, des paramétrages et des logiques de jeu pré-construites. Le Crash Course Kit avec lequel nous vous proposons ici de commencer possède toutes les ressources nécessaires pour le Cours accéléré.

Vous pourrez ainsi vous familiariser avec les principales commandes de l'interface de Stencyl.

Attention Assurez-vous d'avoir téléchargé et installé la version 3.4.0 (ou supérieure) de Stencyl avant de commencer le Crash Course. Le tutoriel ne fonctionne pas avec la version 3.3.0 ou antérieure.

Téléchargez le kit du Cours accéléré

Ce cours accéléré nécessite le kit correspondant, appelé Crash Course Kit en anglais.

1- Téléchargez le dossier disponible ici.

Télécharger

puis

2- Ouvrez l'application Stencyl.

Option 1: Ouvrez le kit dans Stencyl par glisser-déposer

Pour installer le kit, déposez le fichier dans Stencyl comme indiqué ci-dessous.

image DragDropCrashCourse.png (48.7kB)

Option 2: Ouvrez le kit dans Stencyl en utilisant le menu

Vous pouvez aussi importer le fichier à partir du menu fichier (Fichier > Importer un jeu)

Le tutoriel rédigés en 5 étapes ci-dessous reprend de manière détaillée les différentes actions nécessaires à une première prise en main de Stencyl.

La chaîne en français Stencyl Tutoriels FR a publié un tutoriel au format vidéo (durée 53mn) que vous voudrez peut-être voir, avant, pendant ou après:




Créer un nouveau jeu (partie 1 sur 5)

Centre d'accueil

Quand vous ouvrez Stencyl, vous arriverez sur un écran qui ressemble à celui-ci.

image 900pxCentreAccueil.png (0.1MB)

Ceci est le Centre d'accueil. A partir de celui-ci, vous pouvez soit créer un jeu, soit ouvrir un jeu existant.

Créer un nouveau jeu

1. Cliquez sur le rectangle en pointillé appelé "Cliquez ici pour créer un nouveau jeu"

image CreerNouveauJeu.png (2.2kB)

2. Sélectionnez "Crash Course Kit" puis cliquez sur "Suivant" pour utiliser les ressources du fichier.

image NouveauJeu1.png (83.5kB)

  • Qu'est-ce qu'un kit ?
  • Souvent, quand vous créez un jeu sur Stencyl, vous voudrez démarrer avec un kit. Un kit est un gabarit complet de jeu livré avec des ressources, des paramétrages et des logiques de jeu pré-construites.
  • Le kit avec lequel vous commencez possède toutes les ressources nécessaires pour le Cours accéléré.

3. Ensuite, vous verrez apparaitre une fenêtre de dialogue s'ouvrir dans laquelle vous pouvez décider de la taille de la fenêtre de jeu (en pixels) et nommer votre jeu.

Nous allons l'appeler "Crash Course Game", mais vous pouvez l'appeler comme vous voulez.

À propos de cette étape Si vous animez un atelier consistant à accompagner des personnes à suivre ce tutoriel: si vous savez que plusieurs personnes différentes vont faire le même exercice sur le même ordinateur, demandez leur de mettre leur prénom dans le nom du nouveau jeu. En effet les différents jeux créés restent visibles dans le tableau de bord.

En paramétrant la Hauteur et la Largeur dans la section "Taille de l'écran (Web)", vous déterminez la taille de la fenêtre que verra le joueur quand il-elle joue à votre jeu. Dans notre exemple, nous partons avec une largeur de 640 et une hauteur de 480.

Cliquez sur le bouton Créer.

image NouveauJeu2.png (27.5kB)

4. Vous êtes maintenant sur le Tableau de Bord, une zone centrale à partir de laquelle vous pouvez voir et ouvrir vos ressources de jeu (Types d'Acteurs, Arrières-plans, Sons, Comportements d'Acteurs,...)

image 1200pxTableauBord.png (0.3MB)

Ressources de jeu (partie 2 sur 5)


Lors de cette seconde étape, on se contentera d'explorer les différentes ressources. Vous commencerez à programmer dans la troisième partie.


À partir du Tableau de Bord, vous pouvez créer de nouvelles ressources, ainsi qu'en en importer et en ouvrir des existantes. Dans le Cour accéléré, nous avons ajouté toutes les ressources dont vous avez besoin pour commencer. Faisons un petit tour de l'interface.

Acteur Joueur

Nous commencerons par trouver le "Type d'Acteur" qui nous servira de personnage joueur.

Définition : dans Stencyl, tout ce qui peut bouger ou avec quoi il est possible d'avoir une interaction est considéré comme un Acteur. Ceci inclut les personnages joueurs, les ennemis, les éléments d'interface,... Un Type d'Acteur est un gabarit pour les Acteurs, alors que l'Acteur désigne un spécimen particulier appartenant à cette catégorie. Souvent, la communauté utilise les deux mots de manière indifférenciée.
Nous allons donc choisir notre personnage de départ, qui sera Noni, notre bloc vert.

Allez dans RESSOURCES, sélectionnez le Noni dans « Types d’Acteurs », double cliquez dessus pour le faire apparaître dans un nouvel onglet, qui sera l’éditeur de Noni, notre personnage.

image TypesActeursNoni.png (11.7kB)

L’éditeur de personnage est très important, c’est celui qui nous permet de personnaliser notre personnage, pour lui donner des actions. Si vous cliquez sur « Walk Right » par exemple, vous verrez toutes les animations image par image que Noni fera pour marcher vers la droite.

image 900pxEditeurNoni.png (0.1MB)

  • Définition : l’Éditeur de type d'Acteur est l'un des nombreux éditeurs de ressources à l'intérieur de Stencyl. Il vous permet de customiser l'apparence, le comportement et les propriétés physiques d'un Acteur.

Acteur Ennemi

Revenez sur le Tableau de bord, grâce a l’onglet, et répétez l’action pour le Clown, qui jouera notre ennemi.

image TableaubordEnnemi.png (1.8kB)

Tip: Prefer to open things up using the keyboard? Type Ctrl-O (or Command-O on Mac). This will bring up a dialog in which you can type the name of any resource. Use the arrow keys to fine-tune your selection and press Enter/Return to confirm your selection.

Tileset

Définition : un Tileset est un ensemble de tuiles rectangulaires qui peuvent être utilisé pour construire des niveaux de jeu (connues sous le nom de Scènes sur Stencyl), des éléments du décor.
Allez dans le tableau de bord, Jeux de Tuiles, double cliquez sur « Grass Land Tileset » (set de tuiles Herbe), vous l’ouvrirez dans un nouvel onglet, qui sera un éditeur de tuile. En l’occurrence, cette tuile sera le décor de notre jeu.

image 900pxTileset.png (0.2MB)

Sons

Vous remarquerez qu’il y a des sons, qui s’appellent « Jump » (Sauter) et « Stomp » (Écraser), vous pouvez les ouvrir dans un nouvel éditeur, celui du son, mais vous n’avez besoin de les modifier.

image Sons.png (23.0kB)

Comportements d'Acteurs

Dans LOGIQUE, allez dans Comportements d’Acteurs. Vous pouvez voir ci-dessous les cinq Comportements que nous utiliserons dans le Cours accéléré :

image ComportementsActeurs.png (23.8kB)

Vous pouvez ouvrir par curiosité « Die in a Pit and Reload » (Mourrir dans une fosse et Recharger), qui s’ouvrira dans un nouvel onglet, qui vous permettra de voir l’étendue de personnalisation possible.

Cette personnalisation se fait sous forme de programmation par blocs. Dans ce que Stencyl appelle Aperçu de Code ou Design Mode.

Toutes ces lignes expliquent en fait que « Si Noni tombe dans un trou, il meurt, et le jeu recharge à un point antérieur, avant la mort ».

Remarque : les Comportements contrôlent toutes les logiques de jeu et les interactions des joueurs ; c'est ce qui fait "avancer" le jeu.

Jetons un coup d'oeil rapide à l'intérieur de ces Comportements. Double-cliquez sur "Walking" pour l'ouvrir, à l'intérieur du Design Mode.

image 900pxCodeStencyl.png (0.3MB)

Il y a de nombreuses choses à voir ici, mais nous n'en parlerons pas dans ce tutoriel. Le Design Mode est un outil puissant qui permet de concevoir des logiques de comportement complexes. Stencyl propose un tutoriel complet (en anglais) portant sur ce sujet pour vous aider à appréhender les possibilités de cet éditeur de code. Pour le moment, contentez-vous de savoir qu'il existe.

Note: Stencyl propose aussi un "vrai" éditeur de code pour ceux qui préfèraient tout coder à la main au clavier.

Sauvegarde

N’oubliez pas de SAUVEGARDER fréquemment !


Personnalisation des personnages (partie 3 sur 5)


(Nous avons déjà quelques Types d'Acteurs dans notre jeu, mais ils ne sont pas encore très intéressants, car sans Comportements, les ATypes d'Acteurs ne peuvent pas faire grand chose.)

Créer un groupe d'Ennemis

Avant de passer à l’étape de customisation de nos Acteurs, créons rapidement un Groupe pour y mettre les Ennemis.

Définition : les Groupes sont utilisés pour déterminer quels Types d'Acteurs entrent en collision avec quels autres Types d'Acteurs. Les Groupes vous permettent également de traiter différemment les classes de Types d'Acteurs. Un article entier (en anglais) est dédié aux Groupes et à leur impact sur les collisions.
Allez dans « Paramètres », au dessus des onglets, sélectionnez Groupes, Créer Nouveau (bouton vert ), appelez-le « Ennemis ».

Cliquez ensuite sur Joueurs et Tuiles : tout ce qui trouve dans ce groupe peut rentrer en collision avec les Joueurs et les Tuiles.

image CreerGroupeEnnemis.png (11.8kB)

Cliquez sur Ok.

Personnalisons Noni

Ouvrez l’onglet Noni.

Nous avons un personnage, il nous faut maintenant lui dire comment nous voulons qu'il agisse et réagisse (des Comportements) dans certaines conditions. Nous voudrions qu'il puisse:
- regarder à gauche et à droite
- marcher, dans les deux directions
- sauter, dans les deux directions
- sauter sur des ennemis
- "mourrir s'il tombe dans un trou"

Allez dans propriétés afin de vérifier que Noni se trouve dans le groupe des Joueurs.

image NoniJoueurs.png (4.5kB)

Allez dans Physiques pour vous assurer que Noni ne puisse pas tourner. Ici c’est une mauvaise traduction du logiciel, en anglais le logiciel utilise le terme « Rotate », cochez Non afin que les pieds de notre personnage soient toujours au sol.

image NoniTourner.png (31.8kB)

Allez ensuite dans la section Comportements, là où se déroule l'essentiel de la personnalisation. En cliquant sur le bouton Comportements, vous verrez apparaitre l'image suivante :

image 900pxNoniComportements.png (0.2MB)

Double cliquez sur Walking pour ouvrir l’éditeur de comportements. Vous remarquez alors que le logiciel n’est pas complètement traduit en français :
- Right veut dire Droite
- Left veux dire Gauche

Paramétrez de la façon suivante :
- Pour Move right key, qui signifie "Touche pour se déplacer à droite", choisissez Right sur la liste déroulante.
- Pour Move left key, choisissez Left.

Cela veut simplement dire que si vous appuyez sur la touche qui fait se déplacer à droite, Noni ira à droite.

Laissez la Speed (Vitesse)à 15

Pour Idle Right Animation, qui signifie "Animation du déplacement sur la droite", cliquez sur Choisir une Animation, sélectionnez celle qui s'appelle Idle Right.

image NoniIdleRight.png (22.2kB)

Répétez pour les 3 autres animations en dessous.

BRAVO, vous avez édité votre personnage de base ; il peut regarder à droite, et à gauche, il peut aussi marcher à droite, et à gauche !

image NoniIdle.png (17.0kB)

Maintenant, faisons-le sauter

Pour ajouter un comportement, cliquez sur la flèche sur le côté gauche.

image NoniAjout.png (1.2kB)

Vous pouvez ensuite cliquer sur la case centrale en pointillés Cliquez ici pour ajouter un Comportement à attacher à ce Type d'Acteur.

image NoniAjout2.png (4.7kB)

Sélectionnez « Jumping » en double cliquant :
- pour Jump Key mettez Action 1
- laissez la force du Jump à 40
- ajoutez le son Jump
- Mettez les animations Jump Left et Jump Right dans les cases adéquates

Voilà le rendu que vous devez obtenir, ci-dessous.

image 900pxNoniSaute.png (0.2MB)

Recommencez la manœuvre pour ajouter un Comportement et sélectionnez Stomp on Enemies (Écraser les ennemis), puis :
- mettez "Enemis" dans Stompable Groupe
- et "action 1" pour Jump Key

image NoniStomp.png (31.4kB)

image NoniStomp2.png (7.6kB)

Ajoutez de la même manière Die in a Pit and Reload, vous n’avez rien a configurer dedans.


VOILA ! Vous avez fini avec Noni : il se déplace, il saute, ses deux pieds seront toujours sur le sol et s’il saute sur un élément que vous avez ajouté dans le groupe Ennemis (à savoir le Clown, dans notre exemple), il va le tuer. Par contre s’il tombe dans un trou, il meurt.

À propos de cette étape Si vous animez un atelier consistant à accompagner des personnes à suivre ce tutoriel, il peut être plus intéressant de ne pas ajouter le comportement Die in a Pit and Reload à l'étape de personnalisation de Noni. Lorsque les participants en seront à l'étape de Test du jeu, ajoutez une "fosse" à la scène et faites-y tomber Noni hors de l'écran. Constatez qu'il ne se passe rien mais qu'on perd le personnage: le jeu continue mais on ne peut plus jouer! Expliquez alors pourquoi et montrez comment faire pour corriger le bug.

Astuce : les contrôles attribués aux différentes actions et touches se réglent dans Paramètres > Contrôles. Par ex. Action 1, que vous avez indiquée pour faire Sauter Noni, correspond par défaut à la touche Z du clavier. Si vous préférez lui attribuer une autre touche, modifiez les contrôles en conséquence.


Personnalisons le Clown

Allez dans l’onglet Clown : ce sera beaucoup plus rapide, car il demande bien moins de customisation.

Allez dans Propriétés, et ajoutez-le au groupe « Ennemis »

Allez dans Comportements, et ajoutez lui « Stompable » (Piétinable), donnez l'animation et le son « Stomped » (Piétiné), et laissez les valeurs 50 et 40.

Comme vous pouvez le constater, ce comportement rend le clown "piétinable" comme un Goomba dans Super Mario Bros. Le clown "meurt" lorsqu'il est frappé par le haut et émet un son lorsque cela se produit. Si vous cliquez sur le bouton "Modifier le comportement", vous pouvez jeter un coup d'œil au "code" qui se trouve derrière ce comportement.

SAUVEGARDEZ !


Créez une nouvelle Scène (partie 4 sur 5)


Définition : Les scènes sont des niveaux de jeu qui contiennent des tuiles et les acteurs que nous avons créés. Vous pouvez même joindre des Comportements aux scènes, mais nous ne le ferons pas dans ce tutoriel.

Dans le Tableau de Bord', allez dans Scènes, et créez-en une en cliquant sur la case en pointillés au centre.

image 900pxSceneNouveau.png (0.2MB)

Donnez un nom à la scène

"Scene principale" (sans accent, logiciel anglais oblige) par exemple. Laissez les valeurs par défaut.

image 900pxSceneNouveau.png (0.2MB)

Notez bien les champs Largeur et Hauteur des tuiles. Il est impératif qu'ils correspondent à la taille des tuiles des jeux de tuiles que vous utilisez. La taille des tuiles de notre jeu de tuiles est de 32x32, nous laisserons donc ces champs inchangés.

image SceneNom.png (9.9kB)

Dans Couleur de l'Arrière-Plan :
- choisissez "Dégradé Vertical" dans la liste déroulante,
- puis "Sky Blue" et "Light Turquoise" pour les couleurs du fond de décor (vous pouvez choisir d'autres couleurs si vous le désirez), en cliquant sur les zones blanches à droite du menu déorulant,
- Cliquez sur Créer.

image SceneCouleur.png (4.0kB)

Vous êtes maintenant dans un onglet qui s’appelle Scene Principale

image 900pxScenePrincipale.png (0.2MB)

Ajouter des Tuiles

Prenez le Crayon sur la gauche. Il est sélectionné par défaut, normalement.

image Crayon.png (5.0kB)

Cliquez sur une Tuile de couleur verte, en haut à gauche

image Tuile1.png (6.0kB)

Placez-la au bas de votre Scene principale pour commencer le sol de votre Tuile

image Tuile2.png (1.0kB)

Puis cliquez au milieu de la Tuile verte

image Tuile3.png (5.0kB)

Et cliquez à la suite du sol déjà construit, soit plein de fois à la suite, soit en maintenant le clic gauche de la souris, jusqu'à arriver à l'avant dernière case

image Tuile4.png (2.2kB)

Faites ensuite un raccord, avec le coin supérieur droit. Vous devez d’abord cliquer sur la tuile, puis la scène, comme précédemment.

image Tuile5.png (1.5kB)

Placer les Acteurs

Nous allons placer les acteurs :

Allez dans Acteurs en haut à droite, double cliquez sur Noni pour le sélectionner

image TuileActeur1.png (8.9kB)

Placez Noni plutôt à gauche de votre Scène, et placez un ou des clowns (plutôt à droite pour le coup)

Astuce : pour être sur de bien coller les Acteurs à la Tuile (pour qu'ils marchent bien dessus, qu'ils ne "flottent" pas), appuyez sur la touche SHIFT de votre clavier tout en déplaçant les déplaçant
image TuileActeur2.png (2.9kB)

Ajoutez la gravité

Dans le menu « Main Scene », allez dans Physique, et dans Gravité Verticale, mettez la valeur à 85

image Gravite.png (12.9kB)

À propos de cette étape Si vous animez un atelier consistant à accompagner des personnes à suivre ce tutoriel, il peut être plus intéressant de sauter cette étape et tester le jeu. Ce qu'il va se produire, c'est que dès qu'un personnage Noni ou les clowns vont décoller du sol, ils vont s'envoler. Ce sera l'occasion d'expliquer pourquoi (le principe de la simulation de la physique dans les jeux vidéo) et comment résoudre ce problème.

SAUVEGARDEZ !

Testez votre jeu !! (partie 5 sur 5)

Cliquez sur tester la scène dans la barre de menu. Le jeu va se compiler et s'afficher dans une nouvelle fenêtre.

Si vous ne les avez pas modifiés, les contrôles par défaut sont: touche Z pour sauter, touches flèches <- et -> pour se déplacer.

Essayez de sauter sur par dessus et sur les clowns.

Si vous avez bien ajouté le comportement « Die in a Pit and Reload » si Noni tombe et sort du bas de l'écran, la scène va se recharger et le jeu redémarrer au début.


  • Note: vous pouvez rapidement tester votre jeu à n'importe quel moment en utilisant le raccourci-clavier Ctrl-Entrée (ou Command-Entrée sur Mac).



Les ennemis ne sont pas bien aggressifs ni bien dangereux.

Comment faire pour que le jeu s'arrête et recommence si Noni touche un clown?

Il faut créer un nouveau comportement pour ça. Et il y aura plusieurs façons d'arriver au même résultat.

Essayez un Comportement d'Acteurs
- de type "Collision"
- entre Groupes
qui indique que
SI le côté droit d'un acteur du Groupe Joueurs est touché par un acteur du Groupe Ennemis
SI le côté gauche...
ALORS
le jeu se recharge après un fondu au noir d'une seconde.


Tiled, éditeur de cartes

Tiled (parfois aussi appelé Tiled Map Editor) est un éditeur de cartes pour jeu vidéo. La création d'une carte (ou "map", de l'anglais... "map") se fait exactement comme pour la construction d'un toit : tuile après tuile.

Ce logiciel est gratuit et libre. Vous pouvez choisir de faire un don pour soutenir les développeurs du jeu, mais ce n'est pas obligatoire.

www.mapeditor.org

Pourquoi choisir Tiled ?

Facile d'utilisation et de prise en main, il permet de faire à peu près n'importe quel type de map en 2 dimensions :
- Orthogonale, pour les maps vues du dessus,
- Isométrique, pour donner l'illusion de la 3D, comme pour le jeu Zelda ou plus récemment Clash of Clans,
- Hexagonale, est assez similaire à isométrique mais avec des tuiles à base hexagonale.

Le format TMX de sortie du logiciel est lisible par la grande majorité des éditeurs de jeux vidéos, dont Stencyl.

Tutoriel texte

Pour créer une map, vous allez utiliser un ensemble de tuiles appelé tileset. C'est un ensemble de tuiles de motifs différents, que vous allez assembler.

Pour commencer, vous allez utiliser des tilesets déjà constitués, et vous pourrez créer les vôtres plus tard.

Nouvelle carte

Une fois le logiciel ouvert, vous allez créer une nouvelle carte. Trois solutions :
- Fichier > Nouveau > Nouvelle carte
- Appuyer sur le bouton Nouveau > Nouvelle carte
- Appuyez sur les touches CTRL + N

image TMENouvelleCarte.png (40.4kB)

Paramètres à régler :
- Taille de la carte, en hauteur et largeur. C'est le nombre de tuiles qui composeront votre map.
- Taille des éléments, en pixels. Il faut que les pixels correspondent à ceux du jeu de tuiles que vous téléchargez.

Voici ensuite l'interface principale
1 : fenêtre principale, où vous créez votre map. Et nous retrouvons bien nos petite tuiles de 16px par 16px.
2 : le tileset que vous utilisez
3 : les calques, c'est-à-dire les différentes couches sur lesquelles vous allez travailler
4 : vous pouvez charger un tileset à l'aide du bouton juste au dessus du 4 ou en faisant un glisser-déposer dans la zone 2

image TMENouvelleCarte2.png (0.1MB)
Tilesets
Vous allez récupérer les tilesets suivants :
- Rendez-vous sur le site internet Open Game Art
- Cherchez le fichier nommé "Tiled Terrains" ou "[LPC] Terrain Repack", fabriqués par http://poufpoufproduction.fr et disponibles sous licence CC-BY-SA 3.0
- Téléchargez-les sur votre ordinateur, et choisissez l'endroit où vous les rangez pour pouvoir les retrouver.

Maintenant, vous allez les '''charger''' dans Tiled :
- Cliquez en bas à gauche, sur le petit icône blanc avec une étoile jaune

image Tilesets1.png (26.4kB)

- Vérifiez les paramètres des tuiles
image Tilesets2.png (11.6kB)

image Capture_tiled_1.png (6.1kB)

Une fois que vous aurez trouvé votre image, vous devrez aller à droite de l'écran là où il y a le calque. Un moment, il y aura marqué "CALQUE 1". Vous devrez faire un double clic gauche sur le "CALQUE 1" et taper le mot "FOND"

image Capture_tiled_2.png (6.1kB)

1ER CHOIX DE FOND
Une fois que vous avez sélectionné votre fond et qu'il est bien mis, vous devez aller ensuite à droite de l'écran et sélectionner un nouveau calque. Quand vous sélectionnez le nouveau calque, vous faites double clic pour renommer le calque en " PLATEFORME" et ce calque va vous permettre de ne pas effacer votre fond.

image Capture_fond.png (5.5kB)

Vous sélectionnez une tuile pour le fond de votre map (carte)

image Capture_peinture.png (1.2kB)

image Capture_map_tiled.png (0.2MB)

Pour remplir votre fond en un seul coup vous devez cliquez sur l'îcone Pot de peinture qui est dans la barre d'outil en haut de votre écran et vous faites un clic sur la carte.

image Capture_tilrd.png (3.5kB)

Ensuite vous devez sélectionnez Plateforme, puis vous sélectionnez votre carré et vous l'ajoutez sur votre carte que vous êtes en train de créer
Une fois que votre terrain est créé, c'est à vous de créer votre propre environnement, décors, etc... Imaginez votre carte de rêve.

2EME CHOIX DE FOND
Maintenant pour ajouter une finition à votre carte (map) on va rajouter un fond pour que ça soit coloré.

image Capture_tiled_3.png (0.8kB)

Première étape: Cliquer sur le calque

Deuxième étape: Cliquer sur le "calque d'image"
image Capture_4.png (6.7kB)

image Capture_5_tiled.png (7.7kB)

Troisième étape: Cliquer sur l'image qui est située à droite de votre écran et cliquer sur les 3 petits points

Quatrième étape: vous sélectionnez votre image de fond là où vous l'avez enregistrée

(l'image doit être égale ou plus grande que la zone de grille).

image Capture_grille_avec_img_background.png (0.2MB)

Cinquième étape: FIN

Tutoriels vidéos

- Tutoriel en français


0:40 => comment télécharger le logiciel
1:20 => début de l'utilisation du logiciel

- Tuto découverte : https://www.forum-dessine.fr/tutoriels/level-design

- Comment faire des terrains aléatoires en choisissant la répartition des différentes tuiles sur votre terrain. Vidéo en anglais.



- Six tutoriels en anglais. Avec ces tutoriels, vous savez tout faire :
The Basics


Terrain


Auto Map


Objects layers and coding


Creating non-tiled map


et enfin, Isometric maps


Ensembles de tuiles à télécharger

- Packs gratuits sur Final Boss Blues

Sources

- Tiled Map Editor 1 de Maxime Rauld

Filter :  à finir  Animation  Arduino  Article  Auto-formation  Badges  BigBlueButton  CARSAT  cartographie  Cartopartie  Communication  Cookies  Design Tech Académie  DIY  données  Entreprises  EPN  EPN stéphanois  EPN VSE  Family Connection  Foire de Saint-Étienne 2019  Fréquence Écoles  Fusion360  Hinaura  information  Inkscape  Jeux vidéo  La Source Numérique  lien social  Logiciel  Matériel  Mattermost  Médias sociaux  Médiation numérique  MedNum42  Minecraft  Minetest  Modèles économiques  MVCSE  Newsletter  OpenFactory  Openshot  Page à supprimer  Pages sans contenu  Pages sans contexte  PANA  Parentalité  PDN  Piskel  Procédures  Programmation  Projets  Promeneurs du Net  RASPBERRY  Rédaction  Ressources  Retrogaming  RGPD  Robotique  seniors  sexualité  Silo  Sphero  Stencyl  Thymio  Tutoriel  UltimakerCura  Veille  Vocabulaire  Youtube  Zoomacom